Skip to main content
← All vulnerabilities
CVE-2021-23840RUSTSEC-2021-0057BIT-NODE-2021-23840BIT-NODE-MIN-2021-23840GHSA-QGM6-9472-PWQ7

Integer overflow in CipherUpdate

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 111.14.0
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • OpenSSL OpenSSL

    Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i), Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x)

  • openssl-srccrates.io

    From 0.0.0-0 · fixed in 111.14.0

  • openssl-srccrates.io

    fixed in 111.14.0

References 21

openssl.org

git.openssl.org

debian.org

security.gentoo.org

oracle.com

tenable.com

security.netapp.com

lists.apache.org

kb.pulsesecure.net

kc.mcafee.com

cert-portal.siemens.com

GitHub · Trinadh465/openssl-1.1.1g_CVE-2021-23840