Skip to main content
← All vulnerabilities
CVE-2021-23382GHSA-566M-QJ78-RWW5

Regular Expression Denial of Service (ReDoS)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.2.13, 7.0.36
None on Exploit-DB, Metasploit or GitHub

Summary

The package postcss before 8.2.13 are vulnerable to Regular Expression Denial of Service (ReDoS) via getAnnotationURL() and loadAnnotation() in lib/previous-map.js. The vulnerable regexes are caused mainly by the sub-pattern \/\*\s* sourceMappingURL=(.*).

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a postcss

    fixed in 8.2.13

  • postcssnpm

    From 8.0.0 · fixed in 8.2.13

  • postcssnpm

    fixed in 7.0.36

References 3

snyk.io

GitHub · postcss/postcss