Skip to main content
← All vulnerabilities
CVE-2021-23368GHSA-HWJ9-H5MP-3PM3

Regular Expression Denial of Service (ReDoS)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.2.10, 7.0.36
None on Exploit-DB, Metasploit or GitHub

Summary

The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a postcss

    From 7.0.0; fixed in 8.2.10

  • postcssnpm

    From 7.0.0 · fixed in 7.0.36

  • postcssnpm

    From 8.0.0 · fixed in 8.2.10

References 10

snyk.io

GitHub · postcss/postcss

lists.apache.org