Skip to main content
← All vulnerabilities
CVE-2021-23358GHSA-CF4H-3JHX-XVHQ

Arbitrary Code Injection

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.13.0-2, 1.12.1
2 proofs of concept on GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Injection via the template function, particularly when a variable property is passed as an argument as it is not sanitized.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • n/a underscore

    From 1.13.0-0; fixed in 1.13.0-2; From 1.3.2; fixed in 1.12.1

  • underscorenpm

    From 1.3.2 · fixed in 1.12.1

References 17

snyk.io

GitHub · jashkenas/underscore

lists.debian.org

debian.org

lists.apache.org

tenable.com

lists.fedoraproject.org

GitHub · EkamSinghWalia/Detection-script-for-cve-2021-23358

GitHub · MehdiBoukhobza/SandBox_CVE-2021-23358