CVE-2021-23347GHSA-QQ5V-F4C3-395CBIT-ARGO-CD-2021-23347GO-2022-0869SNYK-GOLANG-GITHUBCOMARGOPROJARGOCDCMD-1078291
Cross-site Scripting (XSS)
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.7.13, 1.8.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The package github.com/argoproj/argo-cd/cmd before 1.7.13, from 1.8.0 and before 1.8.6 are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a github.com/argoproj/argo-cd/cmd
fixed in 1.7.13; From 1.8.0; fixed in 1.8.6
- github.com/argoproj/argo-cd/v2Go
fixed in 1.7.13
- github.com/argoproj/argo-cd/v2Go
From 1.8.0 · fixed in 1.8.6
- github.com/argoproj/argo-cdGo
fixed in 1.7.13; From 1.8.0 · fixed in 1.8.6