Skip to main content
← All vulnerabilities
CVE-2021-23193

Improper privilege validation vulnerability in COM Interface of Gallagher Command Centre Server allows authenticated unprivileged operators

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.50.2048 (MR3), 8.40.2063 (MR4), 8.30.1454 (MR4), 8.20.1291 (MR6)
None on Exploit-DB, Metasploit or GitHub

Summary

Improper privilege validation vulnerability in COM Interface of Gallagher Command Centre Server allows authenticated unprivileged operators to retrieve sensitive information from the Command Centre Server. This issue affects: Gallagher Command Centre 8.50 versions prior to 8.50.2048 (MR3) ; 8.40 versions prior to 8.40.2063 (MR4); 8.30 versions prior to 8.30.1454 (MR4) ; 8.20 versions prior to 8.20.1291 (MR6); version 8.10 and prior versions.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Gallagher Command Centre

    through 8.10; From 8.50 · fixed in 8.50.2048 (MR3); From 8.40 · fixed in 8.40.2063 (MR4); From 8.30 · fixed in 8.30.1454 (MR4); From 8.20 · fixed in 8.20.1291 (MR6)

References 1

security.gallagher.com