Skip to main content
← All vulnerabilities
CVE-2021-22940

Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory c

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 12.22.5, 14.17.5, 16.6.2
None on Exploit-DB, Metasploit or GitHub

Summary

Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • NodeJS Node

    From 4.0; From 5.0; From 6.0; From 7.0; From 8.0; From 9.0; From 10.0; From 11.0; From 12.0 · fixed in 12.22.5; From 13.0; From 14.0 · fixed in 14.17.5; From 15.0; From 16.0 · fixed in 16.6.2

References 9

hackerone.com

nodejs.org

oracle.com

security.netapp.com

cert-portal.siemens.com

lists.debian.org

security.gentoo.org