Skip to main content
← All vulnerabilities
CVE-2021-22918

Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 12.22.2, 14.17.2, 16.4.1
None on Exploit-DB, Metasploit or GitHub

Summary

Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether it is beyond pe, with the latter holding a pointer to the end of the buffer. This can lead to information disclosures or crashes. This function can be triggered via uv_getaddrinfo().

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • NodeJS Node

    From 4.0; From 5.0; From 6.0; From 7.0; From 8.0; From 9.0; From 10.0; From 11.0; From 12.0 · fixed in 12.22.2; From 13.0; From 14.0 · fixed in 14.17.2; From 15.0; From 16.0 · fixed in 16.4.1

References 5

hackerone.com

nodejs.org

security.netapp.com

cert-portal.siemens.com

security.gentoo.org