CVE-2021-22904GHSA-7WJX-3G7J-8584
The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service vulnerability in the Token Authent
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 6.0.3.7, 6.1.3.2, 5.2.6, 5.2.4.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service vulnerability in the Token Authentication logic in Action Controller due to a too permissive regular expression. Impacted code uses `authenticate_or_request_with_http_token` or `authenticate_with_http_token` for request authentication.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a https://github.com/rails/rails
Version range not reported
- actionpackRubyGems
From 6.0.0 · fixed in 6.0.3.7
- actionpackRubyGems
From 6.1.0 · fixed in 6.1.3.2
- actionpackRubyGems
From 5.2.5 · fixed in 5.2.6
- actionpackRubyGems
From 4.0.0 · fixed in 5.2.4.6