CVE-2021-22880GHSA-8HC4-XXM3-5PPP
The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnera
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.2.4.5, 6.0.3.5, 6.1.2.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a https://github.com/rails/rails
Version range not reported
- activerecordRubyGems
From 5.0.0 · fixed in 5.2.4.5
- activerecordRubyGems
From 6.0.0 · fixed in 6.0.3.5
- activerecordRubyGems
From 6.1.0 · fixed in 6.1.2.1