Skip to main content
← All vulnerabilities
CVE-2021-22230

Improper code rendering while rendering merge requests could be exploited to submit malicious code.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 13.11.6, 13.12.6, 14.0.2
None on Exploit-DB, Metasploit or GitHub

Summary

Improper code rendering while rendering merge requests could be exploited to submit malicious code. This vulnerability affects GitLab CE/EE 9.3 and later through 13.11.6, 13.12.6, and 14.0.2.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 9.3 · fixed in 13.11.6; From 13.12 · fixed in 13.12.6; From 14.0 · fixed in 14.0.2

References 2

gitlab.com