Skip to main content
← All vulnerabilities
CVE-2021-22185

Insufficient input sanitization in wikis in GitLab version 13.8 and up allows an attacker to exploit a stored cross-site scripting vulnerabi

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 13.8.5, 13.9.2
None on Exploit-DB, Metasploit or GitHub

Summary

Insufficient input sanitization in wikis in GitLab version 13.8 and up allows an attacker to exploit a stored cross-site scripting vulnerability via a specially-crafted commit to a wiki

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 13.8 · fixed in 13.8.5; From 13.9 · fixed in 13.9.2

References 3

gitlab.com

hackerone.com