Skip to main content
← All vulnerabilities
CVE-2021-22119GHSA-W9JG-GVGR-354M

Spring Security versions 5.5.x prior to 5.5.1, 5.4.x prior to 5.4.7, 5.3.x prior to 5.3.10 and 5.2.x prior to 5.2.11 are susceptible to a De

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.5.1, 5.4.7, 5.3.10, 5.2.11
1 proof of concept on GitHub

Summary

Spring Security versions 5.5.x prior to 5.5.1, 5.4.x prior to 5.4.7, 5.3.x prior to 5.3.10 and 5.2.x prior to 5.2.11 are susceptible to a Denial-of-Service (DoS) attack via the initiation of the Authorization Request in an OAuth 2.0 Client Web and WebFlux application. A malicious user or attacker can send multiple requests initiating the Authorization Request for the Authorization Code Grant, which has the potential of exhausting system resources using a single session or multiple sessions.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Spring Security

    Version range not reported

  • org.springframework.security:spring-security-coreMaven

    From 5.5.0 · fixed in 5.5.1

  • org.springframework.security:spring-security-coreMaven

    From 5.4.0 · fixed in 5.4.7

  • org.springframework.security:spring-security-coreMaven

    From 5.3.0 · fixed in 5.3.10

  • org.springframework.security:spring-security-coreMaven

    From 5.2.0 · fixed in 5.2.11

  • org.springframework.security:spring-security-oauth2-clientMaven

    From 5.5.0 · fixed in 5.5.1

  • org.springframework.security:spring-security-oauth2-clientMaven

    From 5.4.0 · fixed in 5.4.7

  • org.springframework.security:spring-security-oauth2-clientMaven

    From 5.3.0 · fixed in 5.3.10

  • org.springframework.security:spring-security-oauth2-clientMaven

    From 5.2.0 · fixed in 5.2.11

References 10

tanzu.vmware.com

lists.apache.org

oracle.com

GitHub · mari6274/oauth-client-exploit