Skip to main content
← All vulnerabilities
CVE-2021-22112GHSA-GQ28-H5VG-8PRX

Spring Security 5.4.x prior to 5.4.4, 5.3.x prior to 5.3.8.RELEASE, 5.2.x prior to 5.2.9.RELEASE, and older unsupported versions can fail to

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.4.4, 5.3.8, 5.2.9
None on Exploit-DB, Metasploit or GitHub

Summary

Spring Security 5.4.x prior to 5.4.4, 5.3.x prior to 5.3.8.RELEASE, 5.2.x prior to 5.2.9.RELEASE, and older unsupported versions can fail to save the SecurityContext if it is changed more than once in a single request.A malicious user cannot cause the bug to happen (it must be programmed in). However, if the application's intent is to only allow the user to run with elevated privileges in a small portion of the application, the bug can be leveraged to extend those privileges to the rest of the application.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Spring Security

    Version range not reported

  • org.springframework.security:spring-security-bomMaven

    From 5.4.0 · fixed in 5.4.4

  • org.springframework.security:spring-security-bomMaven

    From 5.3.0 · fixed in 5.3.8

  • org.springframework.security:spring-security-bomMaven

    fixed in 5.2.9

  • org.springframework.security:spring-security-webMaven

    From 5.4.0 · fixed in 5.4.4

  • org.springframework.security:spring-security-webMaven

    From 5.3.0 · fixed in 5.3.8

  • org.springframework.security:spring-security-webMaven

    fixed in 5.2.9

References 15

openwall.com

lists.apache.org

oracle.com

tanzu.vmware.com