Skip to main content
← All vulnerabilities
CVE-2021-22096GHSA-RFMP-97JJ-H8M6

In Spring Framework versions 5.3.0 - 5.3.10, 5.2.0 - 5.2.17, and older unsupported versions, it is possible for a user to provide malicious

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.3.11, 5.2.18
None on Exploit-DB, Metasploit or GitHub

Summary

In Spring Framework versions 5.3.0 - 5.3.10, 5.2.0 - 5.2.17, and older unsupported versions, it is possible for a user to provide malicious input to cause the insertion of additional log entries.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Spring Framework

    Version range not reported

  • org.springframework:spring-coreMaven

    From 5.3.0 · fixed in 5.3.11

  • org.springframework:spring-coreMaven

    From 5.2.0 · fixed in 5.2.18

  • org.springframework:springMaven

    From 5.2.0 · fixed in 5.2.18

  • org.springframework:springMaven

    From 5.3.0 · fixed in 5.3.11

References 3

tanzu.vmware.com

oracle.com

security.netapp.com