Skip to main content
← All vulnerabilities
CVE-2021-21671GHSA-4WR9-2XC6-JMG5BIT-JENKINS-2021-21671

Jenkins 2.299 and earlier, LTS 2.289.1 and earlier does not invalidate the previous session on login.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.300, 2.289.2
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins 2.299 and earlier, LTS 2.289.1 and earlier does not invalidate the previous session on login.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Jenkins project Jenkins

    From 2.266; From LTS 2.277.1; through 2.299; through LTS 2.289.1

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.292 · fixed in 2.300

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.289.2

References 2

jenkins.io

openwall.com