Skip to main content
← All vulnerabilities
CVE-2021-21648GHSA-GCHQ-9R68-6JWV

Jenkins Credentials Plugin 2.3.18 and earlier does not escape user-controlled information on a view it provides, resulting in a reflected cr

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, and 1 more
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins Credentials Plugin 2.3.18 and earlier does not escape user-controlled information on a view it provides, resulting in a reflected cross-site scripting (XSS) vulnerability.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Jenkins project Jenkins Credentials Plugin

    through 2.3.18

  • org.jenkins-ci.plugins:credentialsMaven

    From 2.3.16 · fixed in 2.3.19

  • org.jenkins-ci.plugins:credentialsMaven

    From 2.3.15 · fixed in 2.3.15.1

  • org.jenkins-ci.plugins:credentialsMaven

    From 2.3.14 · fixed in 2.3.14.1

  • org.jenkins-ci.plugins:credentialsMaven

    From 2.3.8 · fixed in 2.3.13.1

  • org.jenkins-ci.plugins:credentialsMaven

    From 2.3.1 · fixed in 2.3.7.1

  • org.jenkins-ci.plugins:credentialsMaven

    fixed in 2.3.0.1

References 1

jenkins.io