Skip to main content
← All vulnerabilities
CVE-2021-21608GHSA-WV63-GWR9-5C55BIT-JENKINS-2021-21608

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier does not escape button labels in the Jenkins UI, resulting in a cross-site scripting (XSS

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.275
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier does not escape button labels in the Jenkins UI, resulting in a cross-site scripting (XSS) vulnerability exploitable by attackers with the ability to control button labels.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Jenkins project Jenkins

    through 2.274; through LTS 2.263.1

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.275

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.263.2 · fixed in 2.275

References 1

jenkins.io