Skip to main content
← All vulnerabilities
CVE-2021-21607GHSA-CXQW-VJCR-GP5GBIT-JENKINS-2021-21607

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier does not limit sizes provided as query parameters to graph-rendering URLs, allowing attac

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.263.2, 2.275
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier does not limit sizes provided as query parameters to graph-rendering URLs, allowing attackers to request crafted URLs that use all available memory in Jenkins, potentially leading to out of memory errors.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Jenkins project Jenkins

    through 2.274; through LTS 2.263.1

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.263.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.264 · fixed in 2.275

References 1

jenkins.io