Skip to main content
← All vulnerabilities
CVE-2021-21605GHSA-PXGQ-GQR9-5GWXBIT-JENKINS-2021-21605

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier allows users with Agent/Configure permission to choose agent names that cause Jenkins to

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.263.2, 2.275
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier allows users with Agent/Configure permission to choose agent names that cause Jenkins to override the global `config.xml` file.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Jenkins project Jenkins

    through 2.274; through LTS 2.263.1

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.263.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.264 · fixed in 2.275

References 1

jenkins.io