CVE-2021-21426GHSA-M496-X567-F98C
Fixes a bug in Zend Framework's Stream HTTP Wrapper
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 19.4.13, 20.0.9
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Magento-lts is a long-term support alternative to Magento Community Edition (CE). In magento-lts versions 19.4.12 and prior and 20.0.8 and prior, there is a vulnerability caused by the unsecured deserialization of an object. A patch in versions 19.4.13 and 20.0.9 was back ported from Zend Framework 3. The vulnerability was assigned CVE-2021-3007 in Zend Framework.
Timeline
- CVE published
- Record last updated
Affected versions
- OpenMage magento-lts
through 19.4.12; through 20.0.8
- openmage/magento-ltsPackagist
fixed in 19.4.13
- openmage/magento-ltsPackagist
From 20.0.0 · fixed in 20.0.9