Skip to main content
← All vulnerabilities
CVE-2021-21409GHSA-F256-J965-7F32

Possible request smuggling in HTTP/2 due missing validation of content-length

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.61.Final
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.61.Final there is a vulnerability that enables request smuggling. The content-length header is not correctly validated if the request only uses a single Http2HeaderFrame with the endStream set to to true. This could lead to request smuggling if the request is proxied to a remote peer and translated to HTTP/1.1. This is a followup of GHSA-wm47-8v5p-wjpj/CVE-2021-21295 which did miss to fix this one case. This was fixed as part of 4.1.61.Final.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • netty netty

    fixed in 4.1.61.Final

  • io.netty:netty-codec-http2Maven

    From 4.0.0 · fixed in 4.1.61.Final

  • org.jboss.netty:nettyMaven

    All versions

  • io.netty:nettyMaven

    All versions

References 25

GitHub · netty/netty

cve.mitre.org

debian.org

lists.apache.org