Skip to main content
← All vulnerabilities
CVE-2021-21408GHSA-4H9C-V5VG-5M6M

Access to restricted PHP code by dynamic static class access in smarty

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.1.43, 4.0.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • smarty-php smarty

    fixed in 3.1.43; From 4.0.0 · fixed in 4.0.3

  • smarty/smartyPackagist

    fixed in 3.1.43

  • smarty/smartyPackagist

    From 4.0.0 · fixed in 4.0.3

References 9

GitHub · smarty-php/smarty

lists.debian.org

debian.org

security.gentoo.org

lists.fedoraproject.org